Create Method


Creates a new instance of a single Fabric Sheet element within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public static FabricSheet Create(
	Document aDoc,
	Element hostElement,
	ElementId fabricSheetTypeId
)
Visual Basic
Public Shared Function Create ( _
	aDoc As Document, _
	hostElement As Element, _
	fabricSheetTypeId As ElementId _
) As FabricSheet
Visual C++
public:
static FabricSheet^ Create(
	Document^ aDoc, 
	Element^ hostElement, 
	ElementId^ fabricSheetTypeId
)

Parameters

aDoc
Type: Autodesk.Revit.DB Document
A document.
hostElement
Type: Autodesk.Revit.DB Element
The element that will host the FabricSheet. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
fabricSheetTypeId
Type: Autodesk.Revit.DB ElementId
The id of the FabricSheetType.

Return Value

The newly created single Fabric Sheet instance, or a null reference ( Nothing in Visual Basic) if the operation fails.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The document aDoc does not contain the element hostElement -or- the host Element is not a valid host for Area Reinforcement, Path Reinforcement, Fabric Area or Fabric Sheet. -or- fabricSheetTypeId should refer to an FabricSheetType element.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also