Starts a topography surface edit mode for an existing TopographySurface element.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- topoSurfaceId
- Type: Autodesk.Revit.DB ElementId
The TopographySurface element to be edited.
Return Value
The Id of the topography Surface being eddited.Remarks
The application will need to start a transaction to actually make changes to the TopographySurface element. TopographyEditScope can only be started when there is no transaction active, thus it does not work for commands running in automatic transaction mode. Like all Start methods in any edit scope object this too returns an Id of the element in the edit session, even though in this case here it always equals to the given topoSurfaceId.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The ElementId topoSurfaceId does not represent a TopographySurface. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | TopographyEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is a topography surface edit mode active in the document. |