Classes
Class | Description | |
---|---|---|
AddInCommandBinding |
This object represents a binding between a Revit command and one or more handlers which
override the behavior of the command in Revit.
|
|
ButtonData |
Base class used to contain information necessary to construct a button in the Ribbon.
|
|
ComboBox |
This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.
|
|
ComboBoxData |
This class contains information necessary to construct a combo box in the Ribbon.
|
|
ComboBoxMember |
This class represents an item in the drop-down list of a ComboBox.
|
|
ComboBoxMemberData |
This class contains information necessary to construct a ComboBoxMember.
|
|
ContextualHelp |
Contains the details for how Revit should allow invocation of contextual help for an item added by an application.
|
|
DockablePane |
A user interface pane that participates in Revit's docking window system.
|
|
DockablePaneId |
Identifier for a pane that participates in the Revit docking window system.
|
|
DockablePaneProviderData |
Information about a new dockable pane being added to the Revit user interface.
|
|
DockablePanes |
Provides a container of all Revit built-in DockablePaneId instances.
|
|
DockablePanes BuiltInDockablePanes |
A collection of ids of the dockable panes provided by Revit.
|
|
DockablePaneState |
Describes where a dockable pane window should appear in the Revit user interface.
|
|
ExternalApplicationArray |
An array that can contain any number of IExternalApplication objects.
|
|
ExternalApplicationArrayIterator |
An iterator to an array of IExternalApplication objects..
|
|
ExternalCommandData |
A class contains reference to Application and View which are needed by external command.
|
|
ExternalEvent |
A class that represent an external event.
|
|
FilterDialog |
Allows display of the dialog used to create and edit FilterElements in Autodesk Revit.
|
|
PreviewControl |
Presents a preview control to browse the Revit model.
|
|
PromptForFamilyInstancePlacementOptions |
This class contains options to control the behavior of interactive placement of family instances.
|
|
PulldownButton |
The PulldownButton object represents a button with a drop-down list on RibbonPanel.
|
|
PulldownButtonData |
This class contains information necessary to construct a pulldown button in the Ribbon.
|
|
PushButton |
The PushButton object represents an button on a RibbonPanel.
|
|
PushButtonData |
This class contains information necessary to construct a push button in the Ribbon.
|
|
RadioButtonGroup |
Represents a group of related buttons in the Ribbon.
|
|
RadioButtonGroupData |
This class contains information necessary to construct a ribbon gallery in the Ribbon.
|
|
Rectangle |
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
|
|
RevitCommandId |
Represents a command id in Autodesk Revit.
|
|
RevitLinkUIUtils |
A class containing functions for displaying user interface related to
Revit links.
|
|
RibbonButton |
This class is the base class of PushButton and PulldownButton.
|
|
RibbonItem |
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down
which should contain the information for creating one RibbonItem.
|
|
RibbonItemData |
Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
|
|
RibbonPanel |
Represents a panel added by an External Application or External Command into the Add-Ins tab.
|
|
SplitButton |
The SplitButton object represents a button with a clickable button appearing above a pulldown.
|
|
SplitButtonData |
This class contains information necessary to construct a split button in the Ribbon.
|
|
TabbedDialogExtension |
Contains the information required to create and implement the behavior for the new tab inside
the Revit options dialog.
|
|
TaskDialog |
A task dialog is a dialog box that can be used to display information and receive simple input from the user. It has a common set of controls
that are arranged in a standard order to assure consistent look and feel.
|
|
TextBox |
The TextBox object represents text-based control that allows the user to enter text.
|
|
TextBoxData |
This class contains information necessary to construct a text box in the Ribbon.
|
|
ToggleButton |
The ToggleButton object represents a button that has been added to a RadioButtonGroup.
|
|
ToggleButtonData |
This class contains information necessary to construct a toggle button in a RadioButtonGroup.
|
|
UIApplication |
Represents an active session of the Autodesk Revit user interface, providing access to
UI customization methods, events, and the active document.
|
|
UIControlledApplication |
Represents the Autodesk Revit user interface, providing access to
UI customization methods and events.
|
|
UIDocument | ||
UIThemeManager |
Manager object for the UITheme class.
|
|
UIView |
A class containing data about view windows in the Revit user interface.
|
Interfaces
Interface | Description | |
---|---|---|
IControllableDropHandler |
An interface to be executed when custom data is dragged and dropped onto the Revit user interface.
This interface is different from IDropHandler in that it allows the handler to verify whether the drop event can be executed on the given view.
|
|
IDockablePaneProvider |
Interface that the Revit UI will call during initialization of the user interface to gather information about add-in dockable pane windows.
|
|
IDropHandler |
An interface to be executed when custom data is dragged and dropped onto the Revit user interface.
|
|
IExternalApplication |
An interface that supports addition of external applications to Revit.
|
|
IExternalCommand |
An interface that should be implemented to provide the implementation for a Revit add-in External Command.
|
|
IExternalCommandAvailability |
An interface that should be implemented to provide the implementation for a accessibility check for a Revit add-in External Command.
|
|
IExternalEventHandler |
An interface to be executed when an external event is raised.
|
|
IExternalResourceUIServer |
The interface used to provide custom handling of UI operations related to external resources.
|
Delegates
Delegate | Description | |
---|---|---|
TabbedDialogAction |
Delegate for tabbed dialog actions, such as OnOK, OnCancel and RestoreDefaults.
|
Enumerations
Enumeration | Description | |
---|---|---|
ContextualHelpType |
Represents the contextual help type.
|
|
DockPosition |
Which part of the Revit application frame the pane should dock to.
|
|
ExternalEventRequest |
Represents the possible outcomes of a request for raising an external event.
|
|
PostableCommand |
Enumerates all of the built-in commands which can be posted by an API application.
|
|
Result |
Informs Autodesk Revit of the status of your application after execution.
|
|
RibbonItemType |
An enumerated type listing all the toolbar item styles.
|
|
ScrollbarVisibility |
Lists all the visibility types of the scrollbar in the preview view.
|
|
Tab |
An enumerated type listing static tabs which support addition of panels via the API.
|
|
TaskDialogCommandLinkId |
Enum to specify the Id of CommandLink.
|
|
TaskDialogCommonButtons |
A enumerated type containing the standard buttons available for Task Dialogs.
|
|
TaskDialogIcon |
Standard icons to be used in the task dialog.
|
|
TaskDialogResult |
Enum to specify the task dialog result.
|
|
UITheme |
The application frame theme.
|