RemoveSegment Method


Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void RemoveSegment(
	Curve curve
)
Visual Basic
Public Sub RemoveSegment ( _
	curve As Curve _
)
Visual C++
public:
void RemoveSegment(
	Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB Curve
The curve used to locate the segment to be removed.

Remarks

When a segment is removed, the neighboring two panels will be merged into one panel. This function will invoke regeneration.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Segment may not have been found in location indicated by curve.

See Also