GetFileSyntaxErrors Method


Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public IList<string> GetFileSyntaxErrors()
Visual Basic
Public Function GetFileSyntaxErrors As IList(Of String)
Visual C++
public:
IList<String^>^ GetFileSyntaxErrors()

Return Value

An array of strings that are copies of the records in the text file that could not be parsed.

Remarks

Only applies to KeyBasedTreeEntries built from text files.

See Also