Creates a new instance of a piping system type and adds it to the document.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DB Document
The document where the element will be created and added.
- systemClassification
- Type: Autodesk.Revit.DB MEPSystemClassification
The classification for the piping system type to be created
- name
- Type: System String
The name of the piping system type to be created.
Return Value
The newly created piping system type element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | The system classification is not valid for the domain of this system type. |