Creates a rectangular opening on a wall.
Namespace:
Autodesk.Revit.Creation
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wall
-
Type:
Autodesk.Revit.DB
Wall
Host element of the opening.
- pntStart
-
Type:
Autodesk.Revit.DB
XYZ
One corner of the rectangle.
- pntEnd
-
Type:
Autodesk.Revit.DB
XYZ
The opposite corner of the rectangle.
Return Value
If successful, an Opening object is returned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the wall does not exist in the given document. |