AddSegment Method


Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void AddSegment(
	Curve curve
)
Visual Basic
Public Sub AddSegment ( _
	curve As Curve _
)
Visual C++
public:
void AddSegment(
	Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB Curve
The curve used to locate the segment to be removed. This function will invoke regeneration.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Segment may not have been found in location indicated by curve.

See Also