Builds a mesh by extruding curve loop(s) along extrusion distance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profileLoops
- Type: System.Collections.Generic IList CurveLoop
The profile loops to be extruded. The loops will not be modified.
- extrusionDirection
- Type: Autodesk.Revit.DB XYZ
Direction of extrusion. The length of this vector is ignored.
- extrusionDistance
- Type: System Double
The positive distance by which the loops are extruded in the direction of the input extrusionDir.
- materialId
- Type: Autodesk.Revit.DB ElementId
Material which should be used by a constructed mesh.
Return Value
Returns a mesh, which was constructed, and some additional information.Remarks
This function supports creation of a mesh given a collection of continuous curve loops, which are processed independently from each other. Loops with gaps or with curves with wrong flips will be split before processing.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input value cannot be used as thickness for an extrusion, or blend, or wall layer, or similar geometric construct. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | extrusionDirection has zero length. |