Gets the curve loop(s) that represent the bottom or top face of the wall, usable to create an extrusion for the wall geometry.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
- wall
- Type: Autodesk.Revit.DB Wall
The wall.
Return Value
The curve loops. If the function has failed, this collection will be empty.Remarks
This function is intended to help determine if a Revit Wall can be exported as an IfcWallStandardCase. The conditions for exporting an IfcWallStandardCase require that the geometry of the wall be described as one profile curve loop extruded in the Z direction, with potential clip planes and openings applied to the base geometry. This function will use either the top or bottom face to determine the boundary curve loop. Regardless of whether the top or bottom face is used, the curve loop will be located on the plane corresponding to the base of the wall.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |