Add a new distribution system type to project.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: System String
The name of new added distribution system type
- phase
- Type: Autodesk.Revit.DB.Electrical ElectricalPhase
Single or three phase this type is
- phaseConfig
- Type: Autodesk.Revit.DB.Electrical ElectricalPhaseConfiguration
Configuration property of given phase
- numWire
- Type: System Int32
Wire number of this distribution system
- volLineToLine
- Type: Autodesk.Revit.DB.Electrical VoltageType
Type of line to line voltage in this system
- volLineToGround
- Type: Autodesk.Revit.DB.Electrical VoltageType
Type of line to ground voltage in this system
Return Value
New added distribution system type object.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The name can't be a null reference ( Nothing in Visual Basic) , empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown. |