Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- height
- Type: System Double
Distance from the bottom of the wall.
Return Value
The ids of the regions intersected by the specified line.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The height is outside valid range. It should be in the range of [0, SampleHeight]. |