An enumerated type listing all the behavior type for MEP Components.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Invalid | BehaviorType is Invalid |
Normal | BehaviorType is Normal |
Bend | BehaviorType is Bend |
Branch | BehaviorType is Branch |
Intersection | BehaviorType is Intersection |
Inline | BehaviorType is Inline |
BreakInto | BehaviorType is Break Into |
OrientToObject | BehaviorType is Orient to Object |
OrientToCenterLine | BehaviorType is Orient to CenterLine |
OrientToFace | BehaviorType is Orient to Face |
SystemMember | BehaviorType is System Member |
BaseObject | BehaviorType is Base Object |
EndCap | BehaviorType is End Cap |
Valve | BehaviorType is Valve |
Flange | BehaviorType is Flange |
MechanicalCoupling | BehaviorType is Mechanical Coupling |
VerticalBend | BehaviorType is Vertical Bend |
ElectricalBaseObject | BehaviorType is Electrical Base Object |
Straight | BehaviorType is Straight |
Flex | BehaviorType is Flex |
Hanger | BehaviorType is Hanger |
Flat_Tap | BehaviorType is Flat_Tap |
Coupling | BehaviorType is Coupling |
CentreLine_Tap | BehaviorType is Centre-Line Tap |