Links Markups in a DWF file to the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- file
- Type: System String
Full path of the file to link. File must exist and must be a valid DWF file.
- options
- Type: Autodesk.Revit.DB DWFImportOptions
Various link options applicable to the DWF format.
Return Value
A collection of link instance element ids created by the markup link.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Not a valid file for DWF import (.dwf or.dwfx files are valid). -or- Some of the views is not importable. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | The given file does not exist. |
Autodesk.Revit.Exceptions InvalidOperationException | Import is temporarily disabled. |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |