Set the ElementId value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyParameter
- Type: Autodesk.Revit.DB FamilyParameter
A family parameter of the current type.
- value
- Type: Autodesk.Revit.DB ElementId
The new value for family parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the storage type of family parameter is not ElementId --or-- The input ElementId does not represent either a valid element in the document or InvalidElementId. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | Thrown when the input ElementId is not valid as a value for this FamilyParameter. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid. |