Sets the boundary of the view's crop to the specified shape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- boundary
- Type: Autodesk.Revit.DB CurveLoop
The crop boundary.
Remarks
Depending on the shape of the argument, view's crop is set to be either rectangular or non-rectangular. If the crop is set to be rectangular and it is also split, then the multiple view regions will be displayed for the view, with the same proportions as the split prior to the change, but adjusted to the new rectangular shape.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Boundary in boundary should represent one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The crop of the associated view is not permitted to have a non-rectangular shape. |