Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- edgeReference
- Type: Autodesk.Revit.DB Reference
The reference whose edge the object will be created on.
- locationOnCurve
- Type: Autodesk.Revit.DB PointLocationOnCurve
The location on the edge.
Return Value
If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument edgeReference or locationOnCurve is a null reference ( Nothing in Visual Basic) . |