Rotates a set of elements about the given axis and angle.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that owns the elements.
- elementsToRotate
- Type: System.Collections.Generic ICollection ElementId
The set of elements to rotate.
- axis
- Type: Autodesk.Revit.DB Line
The axis of rotation.
- angle
- Type: System Double
The angle of rotation in radians.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given element id set is empty. -or- One or more elements in elementsToRotate do not exist in the document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |