Creates a new radial dimension object using the default dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the dimension is to be visible.
- arcRef
- Type: Autodesk.Revit.DB Reference
Geometric reference of the arc to which the dimension is to be bound.
- origin
- Type: Autodesk.Revit.DB XYZ
The point where the witness line of the radial dimension will lie.
Return Value
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.Remarks
The currently user set default style is used for the created dimension.
Remarks
The dimension will be created on default place.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when any input argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the argument arcRef is invalid. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the creation failed. |