Deletes the specified layer from this CompoundStructure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layerIdx
- Type: System Int32
The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
Return Value
True if the layer was successfully deleted, and false otherwise.Remarks
For a vertically compound structure, a layer may only be deleted if it is not associated to a region, or else it is associated to exactly one simple region, which will also be deleted. Regions associated to layers with index greater than layerIdx will have their associated layer indices decremented by one.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The layer cannot be deleted. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The layer index is out of range. |