Compound
|
Deletes the specified layer from this CompoundStructure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- layerIdx Int32
- Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
Return Value
BooleanTrue if the layer was successfully deleted, and false otherwise.

Exception | Condition |
---|---|
ArgumentException | The layer cannot be deleted. |
ArgumentOutOfRangeException | The layer index is out of range. |

For a vertically compound structure, a layer
may only be deleted if it is not associated to a region, or else it is associated to exactly one simple
region, which will also be deleted. Regions associated to layers with index greater than layerIdx will
have their associated layer indices decremented by one.