Gets a room containing the point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DB XYZ
Point to be checked.
Return Value
The room containing the point.Remarks
Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns a null reference ( Nothing in Visual Basic) .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the point is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue. |