SetEdgeReference Method


Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void SetEdgeReference(
	Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference ( _
	edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference(
	Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also