Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.DB UpdaterId
Id of updater that trigger should be added to
- filter
- Type: Autodesk.Revit.DB ElementFilter
Element filter that defines elements that affect this trigger
- change
- Type: Autodesk.Revit.DB ChangeType
ChangeType associated with this trigger
Remarks
This method only works with CategoryFilter and ParameterFilter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- The id does not correspond to any registered Updaters. -or- AddTrigger called while executing an updater. |