Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- first
- Type: Autodesk.Revit.DB Element
The solid being cut or the cutting solid
- second
- Type: Autodesk.Revit.DB Element
The solid being cut or the cutting solid
- split
- Type: System Boolean
True to split the faces of intersection, false to unsplit them.
Remarks
There must be a cut between the input elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | There is no solid-solid cut between the input elements. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Unable to split or unsplit faces of cutting solid |