Creates a new wall sweep or reveal.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wall
- Type: Autodesk.Revit.DB Wall
The wall upon which to create the new sweep or reveal.
- wallSweepType
- Type: Autodesk.Revit.DB ElementId
The wall sweep or reveal type.
- wallSweepInfo
- Type: Autodesk.Revit.DB WallSweepInfo
The information that describes the new wall sweep or reveal.
Return Value
The new wall sweep.Remarks
The wall sweep's profile and type are taken from the wall sweep type properties. The values set in the WallSweepInfo are ignored.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The wall sweep info represents a fixed wall sweep. Fixed wall sweeps may not be assigned to standalone wall sweep elements. -or- The WallSweepInfo id must be set to -1 for a non-fixed wall sweep. -or- wall may not host a wall sweep or reveal. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |