Adds a new flexible duct into the document, using a point array and duct type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- points
- Type: System.Collections.Generic IList XYZ
The point array indicating the path of the flexible duct, including the end points.
- ductType
- Type: Autodesk.Revit.DB.Mechanical FlexDuctType
The type of the flexible duct.
Return Value
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument points is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the flexible duct type does not exist in the given document. |