SetThermalProperties Method


Sets the thermal properties for the given FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void SetThermalProperties(
	FamilyThermalProperties thermalProperties
)
Visual Basic
Public Sub SetThermalProperties ( _
	thermalProperties As FamilyThermalProperties _
)
Visual C++
public:
void SetThermalProperties(
	FamilyThermalProperties^ thermalProperties
)

Parameters

thermalProperties
Type: Autodesk.Revit.DB FamilyThermalProperties
The new thermal properties. If a null reference ( Nothing in Visual Basic) , this unsets custom thermal properties for this FamilySymbol.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The thermal properties are not valid for assignment.
Autodesk.Revit.Exceptions InvalidOperationException This FamilySymbol does not contain thermal properties.

See Also