Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyParameter
- Type: Autodesk.Revit.DB FamilyParameter
Return Value
The Autodesk::Revit::DB::ElementId^ contained in the parameter.Returns an invalid element id if the storage type of the input argument is Autodesk::Revit::DB::ElementId^ type or this parameter has no value.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument-"familyParameter"-is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the input argument-"familyParameter"-is invalid, |