GetFailureMessages Method


Get all error or warnings created while attempting to load KeyBasedTreeEntries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public IList<FailureMessage> GetFailureMessages()
Visual Basic
Public Function GetFailureMessages As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ GetFailureMessages()

Return Value

A collection of FailureMessage objects, if any errors or warnings were encountered while loading and building the KeyBasedTreeEntries.

Remarks

Revit does not post these warnings. They are provided as a convenience to the API user, who may wish to post them.

The information in the warnings is also captured in the other error functions of KeyBasedTreeEntriesLoadResults.

See Also