Creates new spaces on the available plan circuits of a the given level.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- level
- Type: Autodesk.Revit.DB Level
The level on which the spaces is to exist.
- phase
- Type: Autodesk.Revit.DB Phase
The phase in which the spaces is to exist.
- view
- Type: Autodesk.Revit.DB View
The view on which the space tags for the spaces are to display.
Return Value
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.Remarks
This method will regenerate the document even in manual regeneration mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The view of the relevant level can not be retrieved. |
Autodesk.Revit.Exceptions InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the level does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the phase does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the view does not exist in the given document. |