Add a new wire type to project.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: System String
Name of the new wire type.
- materialType
- Type: Autodesk.Revit.DB.Electrical WireMaterialType
Wire material of new wire type.
- temperatureRating
- Type: Autodesk.Revit.DB.Electrical TemperatureRatingType
Temperature rating type information of new wire type.
- insulation
- Type: Autodesk.Revit.DB.Electrical InsulationType
Insulation of new wire type.
- maxSize
- Type: Autodesk.Revit.DB.Electrical WireSize
Max wire size of new wire type.
- neutralMultiplier
- Type: System Double
Neutral multiplier of new wire type.
- neutralRequired
- Type: System Boolean
Specify whether neutral point is required.
- neutralMode
- Type: Autodesk.Revit.DB.Electrical NeutralMode
Specify neutral mode.
- conduit
- Type: Autodesk.Revit.DB.Electrical WireConduitType
Conduit type of new wire type.
Return Value
New added wire type object.Remarks
Parameter of temperatureRating should be retrieved from parameter of materialType, and parameters such as insulation and maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to fail.