AddWireType Method


Electrical Setting Add Wire Type Method

Note: This API is now obsolete.

Add a new wire type to project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("
                  AddWireType is deprecated in Revit 2026 and will be removed in a future version of Revit. Please use WireType.Duplicate() instead.
                  WireMaterialType object can no longer set to the WireType, use property WireType.WireMaterial instead.
                  TemperatureRatingType object can no longer set to the WireType, use property WireType.TemperatureRating instead.
                  InsulationType object can no longer set to the WireType, use property WireType.Insulation instead.
                  MaxSize object can no longer set to the WireType, use property WireType.MaxSize instead.
               ")]
public WireType AddWireType(
	string name,
	WireMaterialType materialType,
	TemperatureRatingType temperatureRating,
	InsulationType insulation,
	WireSize maxSize,
	double neutralMultiplier,
	bool neutralRequired,
	NeutralMode neutralMode,
	WireConduitType conduit
)

Parameters

name String
Name of the new wire type.
materialType WireMaterialType
Wire material of new wire type.
temperatureRating TemperatureRatingType
Temperature rating type information of new wire type.
insulation InsulationType
Insulation of new wire type.
maxSize WireSize
Max wire size of new wire type.
neutralMultiplier Double
Neutral multiplier of new wire type.
neutralRequired Boolean
Specify whether neutral point is required.
neutralMode NeutralMode
Specify neutral mode.
conduit WireConduitType
Conduit type of new wire type.

Return Value

WireType
New added wire type object.
Remarks
Parameter of temperatureRating should be retrieved from parameter of materialType, and parameters such as insulation and maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to fail.
See Also