Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- type
- Type: System Type
The type to match.
- inverted
- Type: System Boolean
True if the filter should match all elements which are not of the given class.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |