Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
- applyTo
- Type: Autodesk.Revit.DB.Structure StructuralConnectionApplyTo
Specify which type of member this connection type can be applied to.
- name
- Type: System String
A name for the connection type. It must be unique within the document.
- familySymbolId
- Type: Autodesk.Revit.DB ElementId
The id of an annotation FamilySymbol. InvalidElementId is allowed. Otherwise, the FamilySymbol must be in the category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo argument.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to applyTo. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |