Gets the orientation of a segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segmentId
- Type: System Int32
The id of a segment in this CompoundStructure.
Return Value
The orientation of the specified segment.Remarks
The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The segment id is invalid. |
Autodesk.Revit.Exceptions InvalidOperationException | This operation is valid only for vertically compound structures. |