Creates a fabrication part type element based on a specific fabrication service button and condition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- button
- Type: Autodesk.Revit.DB FabricationServiceButton
The fabrication service button.
- condition
- Type: System Int32
The condition index.
Return Value
The created fabrication part type element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the index condition is not larger or equal to 0 and less than ConditionCount |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |
Autodesk.Revit.Exceptions InvalidOperationException | the fabrication part type already exist |