Creates a non-vertically compound structure comprised of parallel layers.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layers
- Type: System.Collections.Generic IList CompoundStructureLayer
An array which describes the parallel layers of this compound structure.
Return Value
A newly created compound structure.Remarks
All layers are in the core, i.e. there are no shell layers created.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more layers is not valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |