Creates a new angular dimension object using the specified dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the dimension is to be visible.
- arc
- Type: Autodesk.Revit.DB Arc
The extension arc of the dimension.
- firstRef
- Type: Autodesk.Revit.DB Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
- secondRef
- Type: Autodesk.Revit.DB Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
- dimensionType
- Type: Autodesk.Revit.DB DimensionType
The dimension style to be used for the dimension.
Return Value
If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when any input argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the creation failed. |