PushTransform Method


Sets the internal transform of the exporter to process the geometry and properties of the input element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public void PushTransform(
	Transform trf
)
Visual Basic
Public Sub PushTransform ( _
	trf As Transform _
)
Visual C++
public:
void PushTransform(
	Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB Transform
The transform.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also