Returns the complete set of element ids that pass the filter(s).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The complete set of element ids.Remarks
This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |