Zoom and center the view to a specified rectangle.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- viewCorner1
- Type: Autodesk.Revit.DB XYZ
A corner of the desired view rectangle in model coordinates.
- viewCorner2
- Type: Autodesk.Revit.DB XYZ
The opposite corner of the desired view rectangle in model coordinates.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The view corner points must differ when projected onto a plane perpendicular to the view direction. |
Autodesk.Revit.Exceptions InvalidOperationException | The view is not a graphical view. |