Adds The CurveElements to one or more FaceRegions.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The Document.
- curveElemIds
- Type: System.Collections.Generic IList ElementId
The ElementIds of CurveElements which are to define the FaceRegion.
Remarks
The CurveElements that are input may produce an arbitrary number of regions.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | All the input CurveElements must be CurveByPoints, with the sketchOnSurface attribute set to True, and for each CurveElement, the defining ReferencePoints must be hosted on References related to a common Face or Edge. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to add curves to FaceRegion. |