Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DB Face
A face of a geometry object.
- location
- Type: Autodesk.Revit.DB XYZ
Point on the face where the instance is to be placed.
- referenceDirection
- Type: Autodesk.Revit.DB XYZ
A vector that defines the direction of the family instance.
- symbol
- Type: Autodesk.Revit.DB FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.