Creates a CompoundStructure containing a single layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layerFunction
- Type: Autodesk.Revit.DB MaterialFunctionAssignment
The function of the single layer.
- width
- Type: System Double
The width of the single layer.
- materialId
- Type: Autodesk.Revit.DB ElementId
The ElementId of the material for the single layer.
Return Value
The newly created compound structure.Remarks
It is not verified that materialId corresponds to a valid Material element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for width must be greater than 0 and no more than 30000 feet. -or- A value passed for an enumeration argument is not a member of that enumeration |