Sets elements that have caused the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idsToShow
- Type: System.Collections.Generic ICollection ElementId
The elements that have caused the failure.
Return Value
The FailureMessage.Remarks
In the Revit error dialog these elements will be highlighted to the user and can be deleted by user via extended error dialog.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This FailureMessage is already posted to a document |