Verifies that the input can be used as a default template for this view type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- templateId
- Type: Autodesk.Revit.DB ElementId
Id to be validated as default template.
Return Value
True if %templateId% is valid as default template, false otherwise.Remarks
The id must represent a template view that is compatible with this view type, or InvalidElementId.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |