Check whether the type of fitting in this section is main.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fittingId
- Type: Autodesk.Revit.DB ElementId
The element id which can be duct fitting and pipe fitting.
Return Value
True if the type of fitting in this section is main False if the type of fitting in this section is branchExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The ElementId fittingId does not correspond to a valid section fitting member. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |