Gets the default view name that will be used when creating a regular schedule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to which the new schedule will be added.
- categoryId
- Type: Autodesk.Revit.DB ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
Return Value
The default view name.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- The Areas category was specified but an area scheme ID was not provided. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |