Namespace:
Autodesk.Revit.DB.Events
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since:
2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Remarks
For synchronizing with central operation, there are 4 steps. 1) Save to local (before save to central) - Serializes the streams from memory to local disk cache; [!:Autodesk::Revit::DB::Events::DocumentSaveToLocalProgessChangedEventArgs] 2) Reload latest - Downloads the streams from central model on server and merge them into local memory; [!:Autodesk::Revit::DB::Events::DocumentReloadLatestProgessChangedEventArgs] 3) Save to central - Uploads merged streams from local memory to server central model; [!:Autodesk::Revit::DB::Events::DocumentSaveToCentralProgessChangedEventArgs] 4) Save to local (after save to central) - Serializes the merged streams from memory to local disk cache; [!:Autodesk::Revit::DB::Events::DocumentSaveToLocalProgessChangedEventArgs]
For document open operation, just download the model from server and then open it; [!:Autodesk::Revit::DB::Events::DocumentOpenProgessChangedEventArgs]
It is NOT recommended to deal with time-consuming work when handling WorksharedOperationProgressChanged event, otherwise it would increase synchronizing with central time.
Inheritance Hierarchy
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DataTransferProgressChangedEventArgs
Autodesk.Revit.DB.Events DocumentSaveToLocalProgessChangedEventArgs